What is the command to do an interactive boot from the ok prompt?
After Power on, press, STOP+A at the ok prompt type:
ok> boot –a
How can u check parameters in ok boot prompt?
To check parameter on the OK prompt:
ok> printenv
How to Formating a disk in solaris?
– add the disk, run devfsadm command.
– then format command > select disk, enter the required details for formating.
– create a new partition table using the format command.
– then create a new file system on it using:
newfs /dev/rdsk/c0t0d0s0 mkdir /mnt mount /dev/dsk/c0t0d0s0 /mnt
– then put its entry in /etc/vfstab.
How do we know how many LAN cards we have in server?
Just Type in the following command at prompt#ifconfig -a.That shall give the LAN Cards as well as total Physical and Logical IP Addresses dmesg – It displays all configured items on systems.
Which command display diagnostics in ok boot prompt?
– Diagnostic Test Commands
1) watch-net % To check network connections
2) test net % To test network conection
3) probe-scsi % To find the devices attached to SCSI BUS.
What is the difference between /dev/dsk and /dev/rdsk?
In Solaris whenever we create a new slice using format command a raw physical slice or a Raw Device will be created which is addressed as /dev/rdsk/c#d#s# where # is the number for slice.
After formatting it with newfs command the slice will be addressed as /dev/dsk/c#d#s# which can now be used for mounting. For example:
# newfs /dev/rdsk/c0d0s4 # mkdir /oracle # mount /dev/dsk/c0d0s4 /oracle
After mounting /dev/dsk/c#d#s# is called as Block Device.
/dev actually contains logical device names which are links (Shortcuts in windows terminology) to actual physical devices in /devices directory.
What command will display the VTOC for disk c0t0d0s0?
To display VTOC of a disk:
# prtvtoc /dev/rdsk/c0t0d0s0
What is the difference between container and zones?
Zones: A zone is a virtual operating system abstraction that provides a secured environment where applications run.The applications are protected from each other to provide software fault isolation.
Container: zone + resource management The ability to control resource usage for processes,task and zones.Resources can be CPU level,RAM,virtual memory,Kernel level tables etc.
What are LDOMS?
Sun Logical Domains or LDoms is a full virtual machine that runs an independent operating system instance and contains virtualized CPU, memory, storage, console, and cryptographic devices. This technology allows you to allocate a system resources into logical groupings and create multiple, discrete systems, each with their own operating system, resources, and identity within a single computer system. We can run a variety of applications software in different logical domains and keep them independent of performance and security purposes. The LDoms environment can help to achieve greater resource usage, better scaling, and increased security and isolation.
What is the use of Growfs utility in solaris?
Growfs is generally used for expanding storage capacity of volume with existing data.
What is the use of ufsdump command in solaris?
To take backup of a filesystem. Syntax of the command is:
ufsdump ouf [Filesystem name]
What file controls system wide password aging?
/etc/shadow file contain the user password information,/etc/default/passwd whith the help of this file we can set the password parameters.
What does fmthard do?
fmthard is tools for copy VTOC (Virtual table of contents)one Hard drive to other Hard drive.
How can i disable STOP+A utility on SUN machines, which brings system into OK> prompt?
There are several ways to disable “STOP-A”
(1)Edit the /etc/default/kbd file.
KEYBOARD_ABORT=disable
(2)Use the “kbd -a disable” command.
# kbd -a disable
(3) Edit /etc/system file.
set abort_enable = 0
What is sticky bit in Solaris?
Sticky Bit is a permission bit that protects the files with in a Directory. If the directory has sticky bit set, a file can be deleted by the owner of the file, the owner of the directory or root. This Prevents a user from deleting other users files from public directories. The sticky bit is displayed as the letter t in the execute field for ‘others’.
What is ndd?
ndd utility is used to examine and set kernel parameters, namely the TCP/IP drivers. To see which parameters are available for a particular driver, use the following ndd command:
# ndd /dev/hme \?
To set parameter using ndd:
# ndd -set /dev/hme link_speed 1; # ndd /dev/hme link_speed ( to view the O/P)
To see which parameters are available ARP, IP, ICMP, and TCP drivers:
# ndd /dev/arp \? && ndd /dev/icmp \? && ndd /dev/ip \? && ndd /dev/tcp \?
What is an alternative to the top command on Solaris?
Command to view performace statistics on Solaris is:
# prstat
What is /etc/system?
Alternative for /etc/sysctl.conf ( linux). The /etc/system file provides a static mechanism for adjusting the values of kernel variables. Values specified in this file are read at boot time and are applied. Any changes made to the file are not applied to the operating system until the system is rebooted.
How can we find RAM size in solaris server?
In Solaris 10 you can find the RAM Size using sdtwsinfo command. This command gives complete Workstation Configuration Information in a pop up window.
What is jumpstart and what are the various steps used in it?
Jumpstart is used to manage operating system installation in many Information technology environments (corporate and otherwise) where Solaris operating system computers are widely used. It can provide easier installation (minor setup on central server, then one command on an installation “client” system to start it installing). It also allows completely consistent system installation on many systems over time – each install can have exactly the same system configuration and software tools../
1. Preparing for a jumpstart server (making export dir)
2. Setting up an Install server
3. Setting up a boot serve
4. Setting up configuration files
5. Making Rules
6. Verifying rules
7. Creating Profiles
8. Sysidcfg file
9. Add a host entry
10. Adding a Client
11. Starting The client Installation
What does the pkgadd command do?
– To install packages in solaris.
Adding package from CDROM:
# pkgadd -d /cdrom/cdrom0/Solaris_9/Product SUNWgtar
Adding packages to spool directory and then install them:
# pkgadd -d /cdrom/cdrom0/Solaris_9/Product -s /var/spool/pkg SUNWgtar
What are the main differences between solaris 10 and 9?
The main difference in solaris 9 & solaris 10 is “SMF(Solaris Management Facility)”. In solaris 9, if any service goes down then we should restart all services this is the disadvantage. But in solaris 10,if any service goes down then that particular service we can select and enable it instead of restarting all services.
What is OBP and how do you access it?
– Open boot Prom this is run level 0 in solaris.
– stop+A or in command mode init 0
– OBP-OpenBootProm is a firmware which is placed on the sun machine’s prom chip. it is a os independent user interface to deal with the sun machine’s hardware components.
– to access it press stop+A (combination) from keybord.
What is LOM and how do you access it?
Lights out management is the abbrevation and some of the Sun severs a use this fecility to emotly operate the Sun sever by conneting a rollover cable from LOM port to a laptop. There is no need to turn on the server , but if the server is just powered , you can connect the laptop to the LOM port and operate the conected Server. you have to inert the ip address of the LOM port in the IE and by this way you can acess the Server to operate it…
What are the different phases in boot process?
Boot phases of Solaris Operating Environment are:
a. boot PROM
b. boot programs like bootblk,ufsboot
c. kernel initialization like loading modules
d. init phase
How to find 32 or 64 bit system instances of OS?
Use the command:
# isainfo –b
What is the command to do an interactive boot from the ok prompt?
stop+a command is to boot an interactive boot from the ok prompt
Give the command that will display your default boot device?
Display default boot device using:
# eeprom boot-device
What is the command can reconfigure devices with out reboot?
To reconfigure devices without reboot, use the command:
# devfsadm
Which NFS daemons are found on the NFS server?
In NFS server side there are 4 deamons. They are:
a. mountd
b. statd
c. lockd