How to find CPU, Memory(RAM), Hard disks, IP address information in AIX

Understanding resource utilization and spare capacity is becoming more important than ever. Processors, Memory are one of the most significant resources among all the available resources in a system, making processor/ memory utilization a critical metric for measuring the performance of a system running a workload.

As AIX Admin In your day-to-day admin job we frequently asked to get CPU and memory values. They will play key roles in administration jobs.

To list presently staged/installed CPU, memory, and hard-disk capacity in the server, use below simple commands on the AIX server.

Show CPU

# prtconf -s
# pmcycles -m
# lsdev -Cc processor
# bindprocessor -q

You can get the CPU utilization of the system with below command:

# mpstat 1

Show RAM/Capacity

# prtconf -m
# bootinfo -r
# lsattr -El sys0 -a realmem
# lsattr -El mem0

Below two commands, shows what is available for processing. Means if the rmss is in place. They will report the simulated memory only.

# vmstat
# getconf REAL_MEMORY

Show Hard disks/Capacity

# lsdev -Cc disk
# lspv
# bootinfo -s hdisk0

Show IP Addresses

# ifconfig -a | grep inet
# lsattr -El en0 -a netaddr

Determining microprocessor speed

This section describes a process for determining microprocessor speed. When using AIX and subsequent releases, the following code returns the processor speed in hertz (Hz):

# lsattr -E -l proc0 | grep "Processor Speed"

When using earlier releases than AIX 5.1, use the uname command. Running the uname -m command produces output of the following form:

xxyyyyyymmss

where:
xx – 00 (always starts with 00 digits)
yyyyyy – Unique CPU ID
mm – Model ID (the numbers to use to determine microprocessor speed)
ss – 00 (Submodel)

Example of “uname -m” command is as shown below:

# uname -m 
00FC76815C00
Related Post