• Skip to primary navigation
  • Skip to main content
  • Skip to primary sidebar
  • Skip to footer navigation

The Geek Diary

  • OS
    • Linux
    • CentOS/RHEL
    • Solaris
    • Oracle Linux
    • VCS
  • Interview Questions
  • Database
    • oracle
    • oracle 12c
    • ASM
    • mysql
    • MariaDB
  • DevOps
    • Docker
    • Shell Scripting
  • Big Data
    • Hadoop
    • Cloudera
    • Hortonworks HDP

How to configure Probe Based IPMP in Solaris 11

by admin

In the last post we have seen how to configure link based IPMP in solaris 11. Let us see how we can configure a probe-based IPMP in solaris 11.

Solaris 11 uses 2 methods for probe-based failure detection
1. Using test addreses (default method)
2. Transitive Probing – No test addresses are used

To enable transitive probing :

# svccfg -s svc:/network/ipmp setprop config/transitive-probing=true
# svcadm refresh svc:/network/ipmp:default

To disable transitive probing :

# svccfg -s svc:/network/ipmp setprop config/transitive-probing=false
# svcadm refresh svc:/network/ipmp:default

To check the Probing method :

# ipmpstat -p

Active/Active Configuration Example (using test addresses)

The configuration details for the active/active IPMP configuration is as below :

IPMP group name  : ipmp0
Active interface : e1000g1 (net1)
                   e1000g2 (net2)

Data IP address  :  192.168.1.10
Test IP address  :  192.168.1.11 and 192.168.1.12

Firstly create the IPMP group ipmp0 :

# ipadm create-ipmp ipmp0

Create the 2 interfaces to be added to the IPMP group :

# ipadm create-ip net1
# ipadm create-ip net2

Add the 2 interfaces we just created to the IPMP group.

# ipadm add-ipmp -i net1 -i net2 ipmp0

Assign the test and data addresses to the respective interfaces :

# ipadm create-addr -T static -a 192.168.1.10 ipmp0/data1
# ipadm create-addr -T static -a 192.168.1.11 net1/test1
# ipadm create-addr -T static -a 192.168.1.12 net2/test2

To check the status of the IPMP group :

# ipmpstat -g
GROUP       GROUPNAME   STATE     FDT       INTERFACES
ipmp0       ipmp0       ok        10.00s    net2 net1

To check the Data address and interfaces in the IPMP group :

# ipmpstat -an
ADDRESS                   STATE  GROUP       INBOUND     OUTBOUND
192.168.1.10              up     ipmp0       net1        net2 net1

To check the individual interfaces status in the

# ipmpstat -i
INTERFACE   ACTIVE  GROUP       FLAGS     LINK      PROBE     STATE
net2        yes     ipmp0       -------   up        ok        ok
net1        yes     ipmp0       --mb---   up        ok        ok
Here m -> the interface is used to send and receive multicast traffic in the IPMP group
b -> the interface is used to send and receive  broadcast traffic in the IPMP group
# ipmpstat -tn
INTERFACE   MODE       TESTADDR            TARGETS
net2        multicast  192.168.1.12        192.168.1.101
net1        multicast  192.168.1.11        192.168.1.101

If you observe the 2nd column above, it shows the mode to identify the probe targets in case of a probe based IPMP configuration. Different modes of failure detection are :
routes – system routing table is used to find probe targets.
multicast – multicast ICMP probes are used to find targets.
disabled – probe based failure detection has been disabled.
transitive – transitive probing is used to for failure detection.

And finally verify the configuration in the ifconfig command output.

# ifconfig -a
lo0: flags=2001000849[UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL] mtu 8232 index 1
        inet 127.0.0.1 netmask ff000000
net1: flags=9040843[UP,BROADCAST,RUNNING,MULTICAST,DEPRECATED,IPv4,NOFAILOVER] mtu 1500 index 7
        inet 192.168.1.11 netmask ffffff00 broadcast 192.168.1.255
        groupname ipmp0
        ether 0:c:29:12:40:79
net2: flags=9040843[UP,BROADCAST,RUNNING,MULTICAST,DEPRECATED,IPv4,NOFAILOVER] mtu 1500 index 8
        inet 192.168.1.12 netmask ffffff00 broadcast 192.168.1.255
        groupname ipmp0
        ether 0:c:29:12:40:83
ipmp0: flags=8001000843[UP,BROADCAST,RUNNING,MULTICAST,IPv4,IPMP] mtu 1500 index 6
        inet 192.168.1.10 netmask ffffff00 broadcast 192.168.1.255
        groupname ipmp0

Active/Standby Configuration Example (using test addresses)

In the active/standby probe-based IPMP configuration, we will set net2 as the standby interface. The configuration details for the active/standby IPMP configuration is as below :

IPMP group name   : ipmp0
Active interface  : e1000g1 (net1)
Standby interface : e1000g2 (net2)

Data IP address   :  192.168.1.10
Test IP address   :  192.168.1.11 and 192.168.1.12

Create the 2 interfaces to be added to the IPMP group :

# ipadm create-ipmp ipmp0

Add the 2 interfaces we just created to the IPMP group.

# ipadm create-ip net1
# ipadm create-ip net2
# ipadm add-ipmp -i net1 -i net2 ipmp0
# ipadm create-addr -T static -a 192.168.1.10 ipmp0/data1
# ipadm create-addr -T static -a 192.168.1.11 net1/test1
# ipadm create-addr -T static -a 192.168.1.12 net2/test2

Assign the test and data addresses to the respective interfaces :

# ipadm set-ifprop -p standby=on -m ip net2

To check the status of the IPMP group (observe the net2 interface in ()) :

# ipmpstat -g
GROUP       GROUPNAME   STATE     FDT       INTERFACES
ipmp0       ipmp0       ok        10.00s    net1 (net2)

To check the IP address of the IPMP interface (observer that we have only net1 as the outbound interface, contrast to the active/active configuration):

# ipmpstat -an
ADDRESS                   STATE  GROUP       INBOUND     OUTBOUND
192.168.1.10              up     ipmp0       net1        net1

To check the status of the individual interfaces :

# ipmpstat -i
INTERFACE   ACTIVE  GROUP       FLAGS     LINK      PROBE     STATE
net2        no      ipmp0       is-----   up        ok        ok
net1        yes     ipmp0       --mb---   up        ok        ok

To check the final configuration :

# ifconfig -a
lo0: flags=2001000849[UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL] mtu 8232 index 1
        inet 127.0.0.1 netmask ff000000
net1: flags=9040843[UP,BROADCAST,RUNNING,MULTICAST,DEPRECATED,IPv4,NOFAILOVER] mtu 1500 index 10
        inet 192.168.1.11 netmask ffffff00 broadcast 192.168.1.255
        groupname ipmp0
        ether 0:c:29:12:40:79
net2: flags=69040843[UP,BROADCAST,RUNNING,MULTICAST,DEPRECATED,IPv4,NOFAILOVER,STANDBY,INACTIVE] mtu 1500 index 11
        inet 192.168.1.12 netmask ffffff00 broadcast 192.168.1.255
        groupname ipmp0
        ether 0:c:29:12:40:83
ipmp0: flags=8001000843[UP,BROADCAST,RUNNING,MULTICAST,IPv4,IPMP] mtu 1500 index 9
        inet 192.168.1.10 netmask ffffff00 broadcast 192.168.1.255
        groupname ipmp0
Solaris 11 – Probe based IPMP configuration
Solaris 11 – Link Based IPMP configuration
Solaris 10 – Probe based IPMP
Solaris 10 – Link Based IPMP

Filed Under: Solaris 11 Tagged With: IPMP, solaris 11

Some more articles you might also be interested in …

  1. How to configure an IP address in Solaris 11
  2. How to configure Solaris 10 Probe based IPMP
  3. Resource management in solaris zones : Dynamic Resource pools
  4. How to create a zone in solaris 11
  5. Comparing Network configuration : Solaris 10 Vs Solaris 11

You May Also Like

Primary Sidebar

Recent Posts

  • qsub Command Examples in Linux
  • qsub: command not found
  • qrcp Command Examples in Linux
  • qmrestore Command Examples in Linux

© 2023 · The Geek Diary

  • Archives
  • Contact Us
  • Copyright